Information submitted through the support site is private but is not hosted within your secure CDD Vault. Please do not include sensitive intellectual property in your support requests.

Web browser requirements

CDD Vault being a software as a service doesn't require any software to be installed on your local computer other than a modern web browser to access it.

Supported are all modern web-browsers on the major platforms Windows, MacOS, and Linux. 

For your security, it is critically important to use an up-to-date browser to access the web. Not only do browsers continuously introduce new features to improve security, but old versions have vulnerabilities that are widely known and are being actively exploited.  

All modern browsers (Google Chrome, Microsoft Edge, Mozilla Firefox, and Apple's Safari) have moved to an "evergreen" model, in which browser updates are automatic. CDD strongly recommends that you use one of these four browsers and verify that the auto-update feature is enabled. In addition to improved security, using one of these browsers will help ensure that the web applications you use load quickly and function correctly.

To check if you have the latest version of your preferred browser, you can check these websites to compare (will open external websites):

Please note, that Microsoft's Internet Explorer is still compatible with CDD Vault, for users of the ELN we do not recommend the IE. Support for this browser by CDD will seize eventually. Please be aware that the development of this browser was discontinued by Microsoft in favor of Microsoft Edge (the latter being fully compatible with CDD Vault).

Furthermore, we recommend to disable any form of ad-blockers, and to allow firewalls access to the two domains:

  • https://app.collaborativedrug.com
  • https://support.collaborativedrug.com

 

Have more questions? Submit a request

0 Comments

Article is closed for comments.